Solutions #00007411
Scope:
ArchiveOne Enterprise, v6.5 or later
Answer:
PROBLEM
You have installed the ArchiveOne Quick Link Client add-in for a 64-bit version of Outlook but when you start Outlook the add-in is not loaded.
SYMPTOMS
When you try to retrieve an archived message the retrieval does not happen instead it just opens the stub message.
In Outlook 2010/2013,
- Click the File tab.
- Click Options.
- Click on Add-Ins. The AOnePolClient Addin is not listed in Active Application Add-ins, Inactive Application Add-ins or in Disabled Items.
ROOT CAUSE
If you look in the installation log (collected by HOWTO: Enable MSI logging for the ArchiveOne Client installation) for the ArchiveOne Quick Link Client you can see:
AppSearch: Property: OUTLOOK15BITNESS, Signature: NewSignature12
MSI (c) (08:B8) [11:55:57:764]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (c) (08:B8) [11:55:57:764]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\Office\15.0\Outlook 3: 2
AppSearch: Property: OUTLOOKBITNESS, Signature: NewSignature11
MSI (c) (08:B8) [11:55:57:764]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (c) (08:B8) [11:55:57:764]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\Office\14.0\Outlook 3: 2
Comparing this to a log from a successful installation:
AppSearch: Property: OUTLOOK15BITNESS, Signature: NewSignature12
MSI (c) (DC:80) [12:13:32:419]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (c) (DC:80) [12:13:32:419]: PROPERTY CHANGE: Adding OUTLOOK15BITNESS property. Its value is 'x64'.
AppSearch: Property: OUTLOOKBITNESS, Signature: NewSignature11
MSI (c) (DC:80) [12:13:32:419]: Note: 1: 2262 2: Signature 3: -2147287038
MSI (c) (DC:80) [12:13:32:419]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\Office\14.0\Outlook 3: 2
Note that both Office version 14 and 15 (2010 and 2013) are checked. If the following lines are not logged:
"PROPERTY CHANGE: Adding OUTLOOK15BITNESS property. Its value is 'x64'"
or
?PROPERTY CHANGE: Adding OUTLOOKBITNESS property. Its value is 'x64'?
when a 64-bit version of Outlook is installed, then the registry keys below either not present or not accessible:
Outlook 2010
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Outlook] "Bitness"="x64"
Outlook 2013
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\15.0\Outlook] "Bitness"="x64"
RESOLUTION
You should forcibly run the MSI for Outlook 64-bit:
- Open a command prompt.
- Browse to the folder where the ArchiveOne Quick Link Client MSI is located.
- Run the command:
For Outlook 2010:
Msiexec /i "ArchiveOne Quick Link Client.msi" OUTLOOK14BITNESS="x64"
For Outlook 2013:
Msiexec /i "ArchiveOne Quick Link Client.msi" OUTLOOK15BITNESS="x64"
Once the installation is complete, confirm you can successfully retrieve a message from Outlook by double-clicking.