We use cookies on our website to ensure we provide you with the best experience on our website. By using our website, you agree to the use of cookies for analytics and personalized content.This website uses cookies. More Information
It seems like your browser didn't download the required fonts. Please revise your security settings and try again.
Barracuda Backup

System, Platform, and Software Compatibility

  • Last updated on

 

This article refers to Barracuda Backup Legacy Release firmware or newer.

See also: Supported Data Sources by Version and Platform

Important
Barracuda makes every effort to test and qualify all hardware platforms and software including operating systems, service packs, and other applications, however, not every combination can be fully tested. However, due to the infinite number of combinations, it is not possible to test every configuration for compatibility. If a specific hardware platform, operating system, browser, service pack, or other application version is not listed as supported, then it has not been explicitly tested and may not be supported even though it may work.

Browser Support

The Barracuda Backup web interface is compatible with the following browsers:

  • Internet Explorer 11.0 and higher
  • Mozilla Firefox 24 extended browser support (ESR) and higher
  • Google Chrome 30 and higher
  • Opera Browser 11.0 and higher

Agent Software Requirements

Microsoft .Net Framework 3.5 is required for Barracuda Backup Agent installation.

Barracuda Backup Agent (Windows) 6.0 and higher supports the following Microsoft Windows systems:

  • Windows Server 2016
  • Windows Server 2012 and 2012 R2
  • Windows Server 2008 and 2008 R2
  • Windows 10
  • Windows 8
  • Windows 7
  • Windows Vista SP1 or higher

 Barracuda Backup Agent (Linux) 6.0 and higher supports:

If your Linux system is running a version prior to Kernel 2.6.16, Barracuda recommends using SSHFS for backup.

  • Kernel 2.6.16 and higher
  • glibc version 2.2.5 for 32-bit binary
  • glibc version 2.3.4 for 64-bit binary

Supported Agent Applications

Barracuda Backup supports all of the latest service packs for Agent applications.

Microsoft Hyper-V

  • Hyper-V 2016
  • Hyper-V 2012 R2
  • Hyper-V 2012
  • Hyper-V 2008 R2
  • Hyper-V 2008

Microsoft Exchange

  • Exchange 2016
  • Exchange 2013
  • Exchange 2010

Microsoft SQL Server

  • SQL Server 2016
  • SQL Server 2014
  • SQL Server 2012
  • SQL Server 2008 R2
  • SQL Server 2008

VMware Support

  • vSphere ESXi 6.5
  • vSphere ESXi 6.0
  • vSphere ESXi 5.5
  • vSphere ESXi 5.1
  • vSphere ESXi 4.1

Cloud LiveBoot for VMware Operating System Compatibility (Windows)

Install virtio drivers whenever possible. There is a maximum of four disks per LiveBoot instance.

If an independent disk is associated with a virtual machine, the virtual machine is backed up but the disk is excluded. Install the Barracuda Agent to capture the disk data.

  • Windows Server 2012 R2 64-bit
  • Windows Server 2012 64-bit
  • Windows Server 2008 R2 64-bit
  • Windows Server 2008 32- and 64-bit
  • Windows 10 32- and 64-bit
  • Windows 8.1 64-bit
  • Windows 8 64-bit
  • Windows 7 32- and 64-bit
  • Windows Vista 32- and 64-bit

Cloud LiveBoot for VMware Operating System Compatibility (Linux/Unix)

Install virtio drivers whenever possible. There is a maximum of four disks per LiveBoot instance.

If an independent disk is associated with a virtual machine, the virtual machine is backed up but the disk is excluded. Install the Barracuda Agent to capture the disk data.

  • CentOS 5.5 32- and 64-bit
  • Fedora 5 and higher 32- and 64-bit
  • Red Hat Enterprise Linux 3 and higher 32- and 64-bit
  • Debian 5 and higher 32-bit
  • Ubuntu 8.04 and higher 32- and 64-bit
  • Knoppix 5.1.1 and higher 32-bit
  • SUSE Linux Enterprise Server 10 and higher 32- and 64-bit
  • openSUSE 11.0 and higher 32- and 64-bit
  • OpenBSD 4.0 and higher 32- and 64-bit (with e1000 network driver)
  • FreeBSD 7.2 and higher 64-bit (with e1000 network driver)
  • FreeBSD 7.4 and higher 32-bit (e1000 network driver)

Local LiveBoot Operating System Compatibility

LiveBrowse Virtual Disk Formats (VMware and Hyper-V)

  • VHD/VHDX Fixed
  • VHD/VHDX Dynamic
  • VMDK Thin
  • VMDK zeroedthick
  • VMDK eagerzeroedthick

LiveBrowse Partition/Volume Structure Support (VMware and Hyper-V)

  • Master Boot Record (MBR) Disks
  • Linux Logical Volume Manager (LVM), single disk/volume only
  • GUID Partition Table (GPT)

LiveBrowse Supported File Systems (VMware and Hyper-V)

  • NT File System (NTFS)
  • FAT File System
  • FAT32 File System
  • Second Extended Filesystem (ext2)
  • Third Extended Filesystem (ext3)
  • Fourth Extended Filesystem (ext4)
  • XFS File System
  • Btrfs File System
  • ReiserFS File System

LiveBrowse Supported Windows Volumes (VMware and Hyper-V)

Supported:

  • Simple

Unsupported:

  • Spanned
  • Striped
  • Mirrored
  • RAID 5 volumes

Linux Supported Backup Methods

  • Barracuda Backup Agent (Linux)
  • SSHFS
  • NFS Mounts
  • Oracle Database on Linux Using RMAN and Barracuda Backup

Mac OS X Supported Backup Methods

  • SSHFS

Hardware and Connectivity Requirements

Verify you have the following before setting up your Barracuda Backup appliance:

  • Barracuda Backup Appliance and AC power cable (shipped with the appliance)
  • Barracuda Backup serial number and linking code (included on the Barracuda Backup Quick Start guide shipped with the appliance)
  • Connectivity and access information for servers to back up
  • VGA Monitor and USB or PST/2 keyboard (recommended/customer supplied)
  • 19-inch rack or stable location in which to place the appliance
  • For Ethernet models, an Ethernet connection is required*
  • For LC Fiber models, an LC SFP or SFP+ connection is required*

*Cabling differs based on the appliance model. For more information, refer to the Barracuda Backup Hardware Specifications.

Source Configuration

 

Last updated on