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How can a Customer resolve message fails to archive as message body is corrupt

  • Type: Knowledgebase
  • Date changed: 3 years ago
Solution #00007299

Scope: 

ArchiveOne Enterprise, all versions.

Answer:

SYMPTOMS

Second phase archiving states that some messages could not be processed, for example:

"Examined 1530 items of which:

Archived 1529 of them

Could not process 1 of them"

Looking at the service tracing, you can see:

30 12:01:41 537677 @ZipMaker_141c *** INFO:Zipmaker Processing message 'RE: Your message' Size: 14307 bytes

30 12:01:41 572462 @ZipMaker_141c This item will be archived in standard mode

30 12:01:41 599230 @ZipMaker_141c ESP: Get property failed 8298001f gives tag 8298000a

30 12:01:41 619534 @ZipMaker_141c ZipMakerIterate::FoundMessage C2CixGetTempDiskSpaceUsage Status 0 DiskSpaceUsage 729366

30 12:01:41 653267 @ZipMaker_141c ZIPMakerIterator::CheckBodyAndAttachments failed to open body 0x8004011b

30 12:01:41 656714 @ZipMaker_141c ZIPMakerIterator::FoundMessage CheckBodyAndAttachments failed, SKIPPING message 'RE: Your message' in folder 'User\Inbox'


ROOT CAUSE

The service trace returns the MAPI error code 8004011b (MAPI_E_CORRUPT_DATA). This indicates the message in Exchange is corrupt and hence can't be processed.


RESOLUTION

As the original data is corrupt in Exchange, you may choose to attempt to recover the message from backup or delete the message from the Exchange mailbox.


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