We use cookies on our website to ensure we provide you with the best experience on our website. By using our website, you agree to the use of cookies for analytics and personalized content.This website uses cookies. More Information
It seems like your browser didn't download the required fonts. Please revise your security settings and try again.
Barracuda ArchiveOne

ArchiveOne Service fails to start as unable to lookup LegacyExchangeDN for service account

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007310

Scope: 
ArchiveOne Enterprise, v5.8 or later.

Answer:
SYMPTOMS
The ArchiveOne Service fails to start. When attempting to start it manually from the Microsoft Services console (services.msc), you see the following error:
"Error 2136 : A general network error occurred."
Error 2136
The following error is visible in the ArchiveOne service trace:
"ReportCriticalFailure:EventLogged Service failed to get LDAP legacyExchangeDN for the search for the primary mailbox."

ROOT CAUSE
Possible causes of this issue include:
*the 'mailnickname' (alias) of the service account has been modified;
*the service account has been deleted;
*the service account's mailbox has been deleted.

RESOLUTION
1. Confirm that the service account user is not disabled, deleted or that the account is locked. The service account should not be hidden from the Global Address List (GAL).
2. Confirm that the mailnickname has not been modified.
1. One or two lines before the 'ReportCriticalFailure' line in the log, you will find the LDAP query that the ArchiveOne service is using to get the Service Account object from Active Directory. E.g.
Startup searching for mailbox, context='DC=demo,DC=com', filter='(&(objectCategory=CN=Person,CN=Schema,CN=Configuration,DC=demo,DC=com)(mailNickname=XXXXXX))'
where XXXXXX is the mailbox alias.
2. Look up the ArchiveOne service account in Active Directory and check that the mailNickname (alias) matches that which is traced in the log file. If it does not, then change the mailNickname (using ADSI Edit or similar) to exactly the same value as found in the trace file.Alternatively uninstall and then re-install ArchiveOne: this will set the correct account details and permissions in order for ArchiveOne to function correctly.

Link To This Page: