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Barracuda ArchiveOne

What does the customer do during journal archiving fails with 0x80040115 MAPI error

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007333

Scope: 
ArchiveOne Enterprise, all versions

Answer:

SYMPTOMS

Journal archiving policy errors due to a problem with processing a message in the first phase. Looking at the service trace you can see:

23 12:20:40 310397 @3c4 *** INFO:Starting processing folder '\Inbox'

23 12:20:40 320502 @3c4 Folder count of items before PDQ is 117945

23 12:29:49 177378 @3c4 Folder count of items after PDQ is 5998

23 12:29:49 181053 @3c4 IterateMessages:OpenEntry for message failed 80040115

23 12:29:49 184755 @3c4 CPublicFolderLimit::AddRepository returning 1

23 12:29:49 188407 @3c4 *** INFO:Completed folder '\Inbox'

23 12:29:49 192118 @3c4 TIME_TRACING:IterateFolders time to call FoundFolder=0.000000

23 12:29:49 195953 @3c4 EPA: Get failed 80040115

23 12:29:49 199678 @3c4 EPA: props=NULL

23 12:29:49 204446 @3c4 PolicyMTIterator::ProcessSubFolders not got folder search flags setting to true

23 12:29:49 208512 @3c4 IterateFolders:GetHierarchyTable returned 80040115

23 12:29:49 212245 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000008

23 12:29:49 215912 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 219607 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000015

23 12:29:49 223138 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 226582 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000013

23 12:29:49 230353 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 234770 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000014

23 12:29:49 238587 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 242380 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000013

23 12:29:49 245864 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 249044 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000014

23 12:29:49 252407 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 255996 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000013

23 12:29:49 259704 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 263011 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000013

23 12:29:49 266624 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 270617 @3c4 TIME_TRACING:IterateFolders time to open folder=0.000013

23 12:29:49 274166 @3c4 IterateFolders:OpenEntry returned 80040115

23 12:29:49 417267 @3c4 PerformanceTest:GAL:OpenEntry:0.139770

23 12:29:49 420564 @3c4 DlistIterator::ConsiderMailbox:OpenEntry failed 80040115

23 12:29:49 423979 @3c4 DlistIterator::IterateDlists found ConsiderMailbox() false (means completed search or error)

23 12:29:49 435310 @3c4 BaseConfigMessage::OpenRootFolder GetReceiveFolder failed 0x80040115


ROOT CAUSE

The PDQ count is a performance enhancement which allows ArchiveOne to quickly scan folder contents and see if further interrogation is required. This is a more intensive activity on Exchange than other actions. If PDQ is applied to a folder containing a large number of messages, Exchange may become unresponsive or timeout depending on its resourcing. The Journal mailbox will typically containing greater numbers of messages in a single folder than a standard user mailbox, as all journalled messages are stored in the Inbox folder by default. It is likely therefore that this issue is only seen when running journal archiving, and not when running mailbox archiving against end-users.


WORKAROUND

You can change the PDQ message limit, so that it is not applied to folders containing large numbers of messages.

Note: This involves editing the Windows machine registry. Using the Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-install Windows to correct them. Barracuda cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk. It is highly recommended that you create a backup of the registry before making any changes.


On the Archive server:

1. Open the Registry Editor by running 'regedit'.

2. Browse to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AOneJournalService\Parameters

3. Create a new DWORD called 'PDQMessageLimit' with value '100'.

4. This will mean that PDQ is not applied to folders containing more than 100 messages, ie. folders containing large numbers of items.Close the Registry Editor.In the Microsoft Services console (services.msc), restart the service 'ArchiveOne Journal Archiving Service' to affect the change.


Now run the journal archiving policy again to confirm that the issue is resolved.


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