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Barracuda ArchiveOne

MMC error when selecting the Mailbox Manager or PST nodes in the ArchiveOne Admin console

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007408

Scope: 

ArchiveOne Enterprise, 6.6 or earlier


Answer:


SYMPTOMS

When selecting the Mailbox Manager, PSTs Discovered and/or Uncoupled PSTs nodes in the ArchiveOne admin console, you see a MMC snap-in error:

MMC Snap-in error


The ArchiveOne service trace shows following lines of logging:

AOneMailboxManagerDatabase::Retrieve failed 0x80004005 (Record is deleted.)

CAMDatabaseServer::Retrieve Retrieve from database failed 0x80004005

And the AOnePolSnap.log shows the following line of logging:

Retrieve found Retrieve2 returned 0x8002000d


ROOT CAUSE

ArchiveOne v6.6 and earlier uses an Access database to store Mailbox Manager data. The error is caused by a rogue deleted row in one of the tables of the Access database. If the error occurs on the Mailbox Manager node, this is the MailboxManager.mdb. If the error occurs on the PSTs Discovered or Uncoupled PSTs nodes, this is the PSTDiscovery.mdb. This can occur if you have attempted to modify the database whilst it is in use by the ArchiveOne service.

It is advisable to upgrade your version of ArchiveOne to the latest version as this uses SQL instead of Access databases.


RESOLUTION

To resolve this error the database should be repaired in Microsoft Access:
  1. Ensure the ArchiveOne Admin console is closed.
  2. On the Archive server, open the Microsoft Services console (services.msc).
  3. Disable and stop the ArchiveOne Service.
  4. Browse to \\Configuration_Server\Add-ins\AOnePol\ServerData
    where Configuration_Server is the name of the Configuration Server (this can be found from the Status node in the ArchiveOne Admin console).
  5. Take a backup copy of the MailboxManager.mdb file (if the error occurs on the Mailbox Manager node) or PSTDiscovery.mdb file (if the error occurs on the PSTs Discovered or Uncoupled PSTs nodes). You can then easily roll back to the original database if required.
  6. If the error occurs on the Mailbox Manager node, open the MailboxManager.mdb in Microsoft Access. If the error occurs on the PSTs Discovered or Uncoupled PSTs nodes, open the PSTDiscovery.mdb in Microsoft Access.
  7. Click on the File tab and select Compact & Repair.
  8. Once the repair is complete, close the database file.
  9. On the Archive server, re-enable and start the ArchiveOne Service.
Open the ArchiveOne Admin console and test that the error is now resolved by selecting the Mailbox Manager or PSTs nodes.