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Barracuda ArchiveOne

How can I resolve Autodiscover fails for a mailbox?

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007431

Scope: ArchiveOne Enterprise, v6.6 or later

Answer:

SYMPTOMS

ArchiveOne uses Exchange Autodiscover to obtain various information about a user's mailbox e.g. the OWA URL to use. It also ensures that information regarding the mailbox is kept current and accurate. For instance, if you are performing a mailbox migration to 365 the user's MailboxDN will change; ArchiveOne uses Exchange Autodiscover to ensure this doesn't disrupt access to the user's mailbox. Autodiscover is used by many actions in ArchiveOne and will therefore appear in various logged functions, for example when checking the user's mailbox details in the background thread 'UpdateDNThread':

08 16:24:04 835096 @UpdateDNThreadfcc AutoDiscover for email 'Andrew.Wilson@aktest2010.com' authenticating as 'ArchiveOneAdmin@aktest2010.com'

08 16:24:04 841392 @UpdateDNThreadfcc AutoDiscover running on machine 'A1-2008R2-2' (AKA 'A1-2008R2-2.aktest2010.com)' by user 'ArchiveOneAdmin' on domain 'AKTEST2010' on Microsoft Windows NT 6.1.7601 Service Pack 1

08 16:24:04 863535 @UpdateDNThreadfcc AutoDiscover URL: https://dc-08r2-ex2010.aktest2010.com/autodiscover/autodiscover.xml

08 16:24:04 876897 @UpdateDNThreadfcc AutoDiscover URL checking: The remote server returned an error: (503) Server Unavailable.

08 16:24:04 879404 @UpdateDNThreadfcc AutoDiscover URL: https://aktest2010.com/autodiscover/autodiscover.xml

08 16:24:06 120739 @UpdateDNThreadfcc AutoDiscover URL checking: The remote name could not be resolved: 'aktest2010.com'

08 16:24:06 123761 @UpdateDNThreadfcc AutoDiscover URL: https://autodiscover.aktest2010.com/autodiscover/autodiscover.xml

08 16:24:06 126718 @UpdateDNThreadfcc AutoDiscover URL checking: The remote name could not be resolved: 'autodiscover.aktest2010.com'

08 16:24:06 129144 @UpdateDNThreadfcc GetProfileProps: The remote name could not be resolved: 'autodiscover.aktest2010.com'

08 16:24:06 130464 @UpdateDNThreadfcc AutoDiscover for email 'Andrew.Wilson@aktest2010.com' got 0 properties. Account may not be enabled for MAPI

08 16:24:06 131746 @UpdateDNThreadfcc ArchiveOne may not be able to connect to this mailbox

ROOT CAUSE

The ArchiveOne Service is unable to connect to the Exchange Autodiscover URL.

RESOLUTION

The URL and the returned HTTP error will be specified in the trace file e.g.:

08 16:24:04 863535 @UpdateDNThreadfcc AutoDiscover URL: https://dc-08r2-ex2010.aktest2010.com/autodiscover/autodiscover.xml

08 16:24:04 876897 @UpdateDNThreadfcc AutoDiscover URL checking: The remote server returned an error: (503) Server Unavailable.

The returned HTTP error will give you an indication as to the issue:

*HTTP 401: Unauthorized

1.HTTP 403: Forbidden
*The ArchiveOne service account should have Full Access permissions on the mailbox for which Autodiscover is being run. If you are prompted to authenticate and you have a proxy server, you should confirm that you are bypassing any proxy authentication requests.

2.HTTP 404: Not found
*This implies you are trying to access a website that requires SSL without using HTTPS. If SSL is configured in IIS Manager for this website and you have a valid SSL certificate, then you should specify HTTPS on the URL. If you do not have a valid SSL certificate for this address, then you should remove the requirement for SSL from the website in IIS Manager.

3.HTTP 503: Service Unavailable
*The website requested was not found on the server. You should confirm in IIS Manager on the server that the website is correctly configured and the content is in the specified location on disk.

*The web service is not running on the web server. You should confirm in IIS Manager that the application pool is running and the website is accessible on the local server.

It may assist you to copy the URL into a web browser as you will be able to see any authentication prompts, page not found, or SSL certificate errors. The URL must be accessible without user intervention.

You may also find running the Autodiscover Test Tool useful to identify any authentication issues as you will be able to explicitly set the user credentials for authentication.