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Barracuda ArchiveOne

PRB: ArchiveOne Search (AOneSearch) website displays Error: Access is Denied

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007490

Scope: 

ArchiveOne Enterprise, all versions

Answer:

SYMPTOMS

When the a user goes to the AOneSearch page they see the message "Error: Access is Denied".   No other information is provided.

As well as the error above, a search of the IIS logs shows this to be a 401.3 error. The user may be able to reach other web pages on the site without problem.  This is usually seen immediately after initial installation.

ROOT CAUSE

Although there are a number of reasons why a web page can report this problem the combination of this message and the IIS log error code points to the fact that the user chosen for "Anonymous Access" to the AOneSearch web site does not have sufficient permissions to read the files in the folder: C:\inetpub\wwwroot\AOneSearch.

WORKAROUND

There is no workaround for this error. The underlying cause must be determined and resolved.

RESOLUTION

The usual resolution is to determine which user is being used as "Anonymous Access" user. This can be obtained by going into IIS on the server hosting the web page, selecting the "Properties" of the AOneSearch page and selecting "Directory Security".  The account named should be granted the following permissions as a minimum:

*Read and Execute

*List Folder Contents

*Read

Setting sufficient permissions for the account should rectify this issue.