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Retrievals, searching or archiving is failing due to missing repository index

  • Type: Knowledgebase
  • Date changed: 3 years ago
Solution #00007496

Scope: 

ArchiveOne Enterprise, all versions

Answer:

SYMPTOMS

Performing an operation which requires the repository index fails, such as retrieving a message or running a search. For example, you attempt to retrieve a message from Outlook using the message stub but see the following error in the Quick Link Client trace:

22 10:54:13   InterpretWebServiceResponse:Error message 'Failed to find message in archive with AOne Server Status of ACSS_SEARCH_NO_INDEX.

ROOT CAUSE

The repository index directory can't be located (e.g. the location is incorrect), or can't be accessed (e.g. due to permissions).

RESOLUTION

You should confirm the repository configuration is correct from the ArchiveOne Admin console:

1. Select the Mailbox Repositories or Journal Repositories node as appropriate.

2. Right-click the repository in question, and select the Index tab.

3. Check the location is correct and that you can browse to this location in Windows explorer to ensure it is valid.

4. If the location is valid, you should also check that the ArchiveOne service account has Full Control NTFS permissions on this Index folder and it is successfully inherited to all subfolders and files.