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Barracuda ArchiveOne

Not all archived messages appear when browsing the ArchiveOne Search website

  • Type: Knowledgebase
  • Date changed: 2 years ago
Solution #00007509

Scope: 

ArchiveOne Enterprise, all versions

Answer:


SYMPTOMS

Only some archived messages are visible in the ArchiveOne Search website when browsing through the mailbox folder list. There is no obvious logic to the range of missing messages; these are across multiple repositories and there are no date ranges missing in their entirely.

In the AOneSearch.log from the web server, you can see the error:

"C2CDatabase::RunQuery failed 0x80040e07 ([Microsoft][ODBC SQL Server Driver][SQL Server]The conversion of a varchar data type to a datetime data type resulted in an out-of-range value.)"



ROOT CAUSE

The language setting in the SQL database for the ArchiveOne service account is not English. The default date format is therefore in an unexpected format and cannot be correctly converted.


RESOLUTION

To modify the language setting for the ArchiveOne service account in SQL Management Studio:

1. Open SQL Management Studio.

2. In the 'Connect to Server' window, enter the SQL instance used by the ArchiveOne installation in the 'Server name' field (e.g. 'SERVER\C2CARCHIVEONE'). If you are uncertain of the instance name, you can check this in the Admin console:

1. Open the ArchiveOne Admin console.

2. Right-click the Status node and select 'Configure...'.

3. Select the Browse Archive tab. The instance name is provided here in the 'Database server' field.Expand 'Databases' > 'C2CBrowseArchiveFolders' > 'Security' > 'Users'.Right-click the ArchiveOne service account user and select 'Properties'.At the bottom of the General page, change the 'Default Language' setting to 'English'.Click OK and close the SQL Management Studio.On the server where the SQL instance is running, open the Windows Services console and restart the 'SQL Server (<instance>)' service.On the archive server, open the ArchiveOne Admin console.Right-click the Status node and select 'Configure...'.Select the 'Browse Archive' tab and click the 'Status' button.Click the 'Flush' button.A new window will open prompting you to confirm you wish to complete this action. Click 'Yes' to flush the database.Once complete, "MSG2800: The browse archive database was flushed successfully" will display. Click 'OK' to close the message.On the Browse Archive Update Status window, click the 'Start' button to begin an immediate synchronization of the database.

You can monitor the progress of the Browse Archive database synchronization from here. The archived messages will now be synchronized with the correct date/time format.