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Barracuda ArchiveOne

Policy fails to complete with error "Unable to connect to Archive One Data Manager Service"

  • Type: Knowledgebase
  • Date changed: 6 months ago
Solution #00007548

Scope: 

ArchiveOne Enterprise, v6.0 or later

Answer:

SYMPTOMS

When attempting to run an archiving policy this fails with the error "Terminated: Unable to connect to Archive One Data Manager Service. Repositories using staged archiving may still have been processed."

The following error can be seen in the ArchiveOne service trace:

21 01:00:17 @fbc PolicyMTIterator::FoundStore failed to open ItemListManager 0x80040154

ROOT CAUSE

The error 0x80040154 (REGDB_E_CLASSNOTREG) indicates that the ArchiveOne Data Manager Service is not correctly registered.

RESOLUTION

You can attempt to manually register the ArchiveOne Data Manager Service x64 (in versions prior to 7.3, named ArchiveOne Data Manager Service):

A: If the Filter Services are not listed in the Microsoft Services Manager (services.msc), otherwise see section B.

  1. On the Archive server, open a command prompt as an Administrator.
  2. Browse to: C:\Program Files (x86)\Barracuda\ArchiveOne
    • For older versions than v7: C:\Program Files (x86)\C2C Systems\ArchiveOne
  3. Run the command: AOneItemListServicex64.exe /service
    • For older versions than v7.3: AOneItemListService.exe /service
  4. The ArchiveOne Data Manager Service x64 should now be listed in the Microsoft Services Manager (services.msc) with Startup type set to Manual.

B: If the ArchiveOne Data Manager Service x64 is listed in the Microsoft Services Manager (services.msc), but may not be registered properly:

  1. On the Archive server, open the Microsoft Services Manager (services.msc).
  2. Stop the ArchiveOne Data Manager Service x64, if it is running.
  3. Close the Services Manager.
  4. Open a command prompt as an Administrator.
  5. Browse to: C:\Program Files (x86)\Barracuda\ArchiveOne
    • For older versions than v7: C:\Program Files (x86)\C2C Systems\ArchiveOne
  6. Run the command: AOneItemListServicex64.exe /UnRegServer
    • For older versions that v7.3, run the command: AOneItemListService.exe /UnRegServer
  7. Open the Microsoft Services Manager (services.msc) and verify that the ArchiveOne Data Manager Service x64 is not listed.
  8. Close the Services Manager.
  9. In the command prompt run: AOneItemListServicex64.exe /service
    • For older versions that v7.3, run the command: AOneItemListService.exe /service
  10. The ArchiveOne Data Manager Service x64 should now be listed in the Microsoft Services Manager (services.msc) with Startup type set to Manual.

If this fails to resolve the error, then a re-installation of ArchiveOne is required to resolve the incorrect service registration as there is a likely a registry entry mismatch. If you are not running the latest product version, then this is a good opportunity to upgrade to the latest release.