Solution #00007309
Scope:
PST Enterprise, v3.2 or earlier.
Answer:
SYMPTOMS
After installing PST Enterprise and browsing to the Client Configuration tab of the web console the user sees an error message:
?Call to webservice failed?.
ROOT CAUSE
There are two IIS handlers missing from the web.config file.
RESOLUTION
- On the PST Enterprise server, browse to: C:\Program Files (x86)\Barracuda\PSTEnterprise\Web
- Take a backup copy of web.config file (in case you need to revert any changes).
- Open the web.config file in Notepad.
- Add the following text to the <system.webServer><handlers> section:
<add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
<add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> - Save the modified web.config file.
Reload the Client Configuration tab and confirm the error is resolved.
Link To This Page: